[email protected]:~# apt-get install vim Reading package lists... Done Building dependency tree Reading state information... Done Package vim is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'vim' has no installation candidate I work on a Debian Lenny dist (stable) I have updated the sources list following the instructions above and have applied the patch attached to the bug. Then, I have had to install the sun-java6-bin package to get working. In my experience the hudson does not start with the debian gnu java. I obtained an exception related to this message:

The chain of trust in Debian starts (e.g.) when a maintainer uploads a new package or a new version of a package to the Debian archive. In order to become effective, this upload needs to be signed by a key contained in one of the Debian package maintainer keyrings (available in the debian-keyring package). The package libapache2-mod-php5.6, php5-dev, php5-mysql,php5-curl can be installed only on debian Wheezy (7) , Jessie (8) or Sid . Also the ondrej/php repository does not provide those package for debian Stretch it is only provide the php5.6 package. Debian install of ROS Kinetic. We are building Debian packages for Debian Jessie. These packages are more efficient than source-based builds and are our preferred installation method for Debian. Note that there are also packages available from Debian upstream. Please see UpstreamPackages to understand the difference.